Category Archives: Products I use

Getting Data Protection Manager agent to work on remote servers

I am now using Microsoft Data Protection Manager 2010 to handle backups of my personal Exchange mail server.  It took a while to figure out how to set this up since I had never used this product before and knew nothing about it until talking to my instructor at a recent Exchange 2010 training class I attended.  I learned a few tricks that may help someone else quickly avoid problems during a deployment of DPM 2010. 

First, DPM server must be a standalone server, it cannot be installed on an Exchange server or a domain controller.  In addition, you should install the AD management tools on the server as without them you will get a cryptic error message telling you that the server cannot communicate with AD and thinks you are in a workgroup or have a mis-configured DNS client. 

Now that you have the DPM Server installed, its time to deploy the agent.  You can deploy the agent to remove computers from a wizard driven interface, however I found that this did NOT work for me at all.  I had to manually install the agent by running the agent installer directly from the C:Program FilesMicrosoft Data Protection ManagerDPMProtectionAgents.  Think you are done…not quite!  Now open a command prompt and navigate to the DPMbin directory.  Execute this command “setdpmserver -dpmservername nameofyourserverhere” and press enter.  for the servername, use the FQDN (i.e. servername.domain.local).  The documentation says to use domainservername, but this DOES NOT WORK. 

One you do the above, you can go into the services control panel and set the DPM server service to automatic and start it.  Now you can go to your DPM server and configure protection groups and add member servers.  Enjoy!

Advertisements

Yes you can activate a clean install of Windows 7 with an upgrade product key

I am not promoting piracy, but I ran into a nasty little problem when I tried to activate Windows 7 on my home computer.  Maybe this post will help others like me who can’t get help anywhere else. 

In anticipation of obtaining my Windows 7 Pro upgrades (which I ordered in July on the pre-order 50% off sale) I installed Windows 7 Pro using a clean install without entering a product key for activation on two of my computers.  My laptop and my main home computer.  Both computers were clean installs on either a new hard drive or a new partition.  On my laptop I resized my partitions and installed Windows 7 on a new partition separate from Windows Vista.  So now its in a dual boot configuration with Windows Vista and Windows 7. 

On Thursday, I got my upgrade product keys from the Microsoft store and went to activate my computers.  On my laptop the activation was successful wtihout a problem.  Then I went to activate my home computer and got the error telling me that I can’t use an upgrade product key to activate a clean install of Windows 7.  So now I am left with a fully loaded PC running Windows 7 with only 10 days left to activate before I either have to re-arm or enter a new product key.  It takes hours to backup and restore the data on this PC, its my wife’s main computer and we have tons of stuff to backup and move around.  I’d pay a fee to avoid having to do this! 

The home computer was running Widnows Vista 32-bit Home premium edition.  It got upgraded to Windows 7 Pro 64-bit using a clean install method.  A while after I had installed Windows 7, I decided to cleanup the old hard drive that had the Windows Vista install on it because I wouldn’t need it anymore.  So I can’t even go back to Vista without having to do a clean install of Vista first which is something I want to avoid.  But from my understanding you can’t upgrade a 32-bit OS to the 64-bit version, so I have to do a clean install anyway.  But now that I’ve wiped out the hard drive that had Vista on it, so the activation wizard can’t see the old OS and won’t let me use my upgrade key.  I heard hints in various forums that the activation wizard looks for partitions with an upgradable OS on it. 

On my laptop, I still have the partition with Activated Windows Vista home premium 64-bit because of the dual boot setup, so I think thats why the activation wizard let me activate my laptop without a problem.  So what can we do in a situation like this?  Call Microsoft, take a huge risk and investigate non legit options?  

I had thought about trying to run the Retail upgrade install of Windows 7 on my home PC and use my upgrade key for activation.  The reason I had hope that this might work is because my home PC was loaded using the RTM Windows 7, and the download I got from Microsoft was the official retail media, so there is a very small chance it may have let me do another upgrade using my upgrade key and then possibly activate successfully.  My other thought was to install windows Vista on a spare hard drive and just leave it in my PC when booted up to Windows 7 and see if the Windows 7 Activation wizard will recognize a valid copy of Windows Vista and let me activate using my upgrade key. 

I was getting desperate since it could easily take two days to reload my home computer and go through all the trouble to get Windows 7 running again!  This is such a pain!  It shouldn’t be this hard for legit customers to use Microsoft software!!!

Ok, now that the rant is over, let me tell you how to get around this problem and get your Windows 7 systems activated.  This is actually very easy and only took a few minutes.  To my knowledge there is nothing underhanded or risky about this procedure.  Its also not well documented, it took me two days of google research and massive searches to find the information that helped me. 

Thanks to Winsupersite.com community for this information!

After performing the clean install, ensure that there are no Windows Updates pending that would require a system reboot. (You’ll see an orange shield icon next to Shutdown in the Start Menu if this is the case).  Install the updates and reboot if necessary before proceeding.

Then, open regedit.exe with Start Menu Search and navigate to:

HKLM/Software/Microsoft/Windows/CurrentVersion/Setup/OOBE/

Change MediaBootInstall from “1” to “0”.

Open the Start Menu again and type cmd to display a shortcut to the Command Line utility. Right-click this shortcut and choose “Run as administrator.” Handle the UAC prompt.

In the command line window, type: slmgr /rearm

Then click OK, close the command line window and reboot. When Windows 7 reboots, run the Activate Windows wizard (go to system properties and click the activate windows link at the bottom of the window), type in your upgrade product key and activate windows.  It should activate successfully and you are now finished!  Congratulations on saving yourself hours (or days in my case) of wasted time jumping through hoops trying to get your genuine Windows 7 installation activated!

Migrating to Windows 7

Yesterday, I upgraded my work PC to Windows 7 professional.  I wanted to give the upgrade a try and see how it would go, but normally I prefer to do clean installs.  The upgrade process took about 2-3 hours but did retain all my applications and most settings.  I did have to remove some HP software that came with the PC, but overall it wasn’t too bad.  I had some additional trouble with Ultramon that caused some errors and weird behavior with the taskbar.  Here are some observations so far:

1. The taskbar is taller and takes up more screen real estate.  This isn’t necessarily bad, but takes some getting used to.  It makes the icons look smaller. 
2.  The quick launch bar has been transformed into something different, mabye better, not sure yet.  I was dismayed to find out that the upgrade had wiped out my quick launch folder completely, all my pre-arranged shortcuts were just gone!  I found a way to work around this by creating a new quick launch folder manually and moving shortcuts that I wanted in the list.  I wish I had backed up my quick launch folder before the upgrade! 
3. The transparency is nice, but at times a little weird.  Since the top inch or so of many apps is now transparent, it seems like your apps are not maximized or as if there is a big gap at the top of the screen. 
4.  I think its cute how the new network connection icon in the task bar looks like it has a pitch fork in it.  🙂
5.  I like the new start menu, specifically the ability to expand options for programs such as RDP.  Now when you go to RDP in the start menu, it gives you an expandable list of recent connections, which I think is nice, even though I use mRemote to organize my RDP connections.  
6. Performance seems good, the PC boots up pretty fast especially considering it was an upgrade install. 

The official upgrades for my home computers will be available in a few weeks, so I’ll post back later on with more observations.

Switching from Windows Mobile to the iPhone 3GS

Last week I upgraded my cell phone from an HTC Tilt running Windows mobile 6.1 (custom cooked Rom) to the 32GB iPhone 3GS.  I wen to the at&t store on Dale Mabry and Henderson and was surprised at how nice of a store it was.  I had no lines and no waiting and was able to get in and out with my upgrade in about 10 minutes. 

So now that I’ve had my new iPhone for  a week now, here are some thoughts and notes about my switch…

Things I miss from Windows Mobile:
   1. The ability to control the volume for PDA sounds and the ringer separately.  At night I used to mute the PDA sounds and leave the phone ringer on maybe 2 bars.  This worked out great for me as I’m on call 24/7, so witching my phone to silent or even putting it on vibrate is not a great option for me.  Maybe one day this will be available as a feature on the iPhone.

   2. Easier file management.  I miss being able to just connect my phone to my PC and copy files back and forth via windows explorer.  Having to use iTunes to simply put files on my phone is a bit of a pain, epsecially when I’m not around my home computer and want to copy something to my iPhone.  I know there are 3rd party apps out there to help with this, but the lack of built in file management is a bit of a pain.  Not to mention that much more limited range of file types you can actually use on the iPhone.

What I love about the iPhone:
   1. The interface!  Its easy to use, visually appealing, clean and responsive.  Windows Mobile can be a bit slow at times and more complicated to navigate through screens and various settings. 
   2. It just works, right out of the box I was able to connect it to my bluetooth radio in my car for hands free calling.  I didn’t have to run through any setup wizard to align my screen or anything like that.  It just worked. 
   3. Easier to get apps!  There are many apps for windows mobile, but you have to go hunting for them, and most of the good ones cost money!  The iTunes app store has many apps available and a good number of them are free, some good ones too!  I love being able to tap “install” and it just goes to work and then you can open the app and begin using it.  

Some problems with the iPhone:
   1. The mail client lacks the enterprise grade functionality and reliability that I’ve come to get used to with Windows Mobile.  I’ve tried different types of mail accounts (activesync and MAPI, etc), and I’ve seen inconsistent behavior with the push functionality.  For example, I have an Exchange account setup and sometimes I’ll notice an hour delay in getting notified of new mail.  I can be on either 3G or wifi and it still happens.  Its just not as reliable for instant e-mail notifications. 

   2. I really really wish I could control PDA sound volume (email alerts, notifications, etc) separately from the phone ringer.  This is huge for me! 

Overall, I love my new iPhone.  Its awesome to have my mobile phone and my iPod all in one device.  It works great with other technologies I employ in my daily life.  Some people get a little uptight about losing some enterprise business features or reliability on the iPhone, but thats not really the target audience anyway.  And really, most post people are not going to care if they can’t edit Microsoft Office documents on their iPhone, they just want to be able to read and reply to e-mails on the go and are completely happy to do the PC work on the PC and just enjoy the iPhone for what it is.

Have to click user icon to unlock Windows Vista

Something happened to my Windows Vista desktop that I use primarily at work.  To explain the issue, here is some background information.  I normally lock my computer anytime I step away from it to prevent un-authorized access.  It used to be that I could just hit CTRL+ALT+DEL and type in my password and press (Return|Enter) to unlock my machine.  However, in the last week or so instead of bringing up the password field for the logged on user when you hit CTR+ALT+DEL, what you get instead is an icon for the username which you then have to click or just hit enter before you type in the password.  Now this may not sound like much of a problem, but when you are used to something happening a certain way, changing that makes a difference.  I didn’t change any of my user options in Vista, so I am guessing that this is a change from a recent update or something from Microsoft.  I don’t have access to many Vista machine to test this on, but I am curious if anyone else has seen this before and if you know how to fix it.  If I find a solution I will post it here, but for now I am still looking.  I just want to hit CTRL+ALT+DEL and type in my password to logon, I don’t want to have to click on my user icon or have an extra key press before I can put in my password.  Maybe thats just me being set in my ways…

Add recipients of sent items to the Outlook auto fill cache

This is a great utility (also free) that will allow you to add the recipients of your sent items to the Outlook auto fill cache.  This is great if you reload a PC or in any number of other solutions.  Click here to read more about it and download this great utility.

Outlook auto fill list management

Here is a great little tool from NirSoft that allows you to edit, backup and manage your Outlook auto fille cache file or .n2k file.  This is great for backup or combing through to fix a corrupt or otherwise incorrect entry without having to scroll through the list in Outlook.  Click Here to read more about it and download this completely free tool. 

Bizzare issue without outbound faxing through e-mail and Public folders

I recently ran into some very strange issues with an older fax through e-mail solution.  The setup is a mixed Exchange 5.5 (unsupported) and Exchange 2003 site with an old version of RightFax from Captaris (version 8.5 – unsuppored).  After years of working in this configuration, suddenly the outbound fax abilities quit working and you would receive NDR messages anytime you sent an outbound fax.  Incoming was working without problems, only outbound fax through e-mail was a problem.  I checked the Exchange connector for RightFax on the Exchange 5.5 box which was fine, there were some side issues there where some .tmp files weren’t getting purged properly, but I couldn’t find a cause for the issue we were having.  Reboots were done in hopes this would help resolve the issue, but they did not help.  The only errors I was receiving were as follows:

Exchange cannot determine a route for this message or no next hop can be determined.   A routing group topology does not have a routing group connector set up between the routing groups.  Mail destined to a routing group that does not have a routing group connector to connect it to other groups cannot be sent.   

Solution: Add or configure your RGC between RGs

 

and

 

The domain ‘$MSGWIA$.FAX.*’ is unreachable.

 

No route was found for the recipient server.  Please contact your system administrator.
            <servername.domain.private #5.4.4>

After a few days of researching and trying to find a solution to this issue, I happen to notice that I had another problem.  In the Exchange 2003 ESM I could not browse the public folder tree.  I’ve had this issue before and seen various things cause it, so I began researching the exact error codes I received.  (sorry I didn’t write those down, but they said something like “503 service unavailable” when I tried through OWA). 

I ended up restarting the Exchange 2003 HTTP Virtual server from ESM, and also dismounting and re-mounting the public folder store.  After I did that I noticed some events in my application log basically saying the route for FAX was online and mentioned our fax server name.  Out of curiosity I tried sending an outbound fax through e-mail and it worked!  I then asked the staff in the location where the issue was originally reported to try sending some test faxes through e-mail but they reported back and said it was still not working.  I then performed the same steps I mentioned above on all Exchange 2003 servers which seemed to fix the issue of not being able to view the public folder tree in ESM, but also had the side effect of fixing the outbound fax issue. 

I have no idea how an old fax system could possibly be tied into the public folder system of Exchange 2003.  I have no support for either Exchange 5.5 or the version of RightFax we are using, so I will probably never know.  I do know that the two issues were related somehow and the same solution for fixing the public folder tree view in ESM also fixed our outbound fax issues.  I think this is very strange but am glad the system is working again.  I hope this will not delay replacing these old systems and they still need to be replaced asap. 

Apple iphone/itouch firmware 2.2

I have been toying around with the new 2.2 firmware for my ipod touch (2nd Gen).  I had been really excited to check out the new podcast features in the itunes app, but alas, its not as good as I had hoped.  It turns out that the new podcasting features of the itunes app are independant of your itunes configuration.  So you might have a list of podcasts you are already subscribed to in itunes, but none of them show up on the touch.  Podcasts (a new menu item in the itunes app on the iphone/touch) are indepednant of what you have in itunes.  While this new functionality is still cool, it would have been nice to import my itunes podcasts as those are the ones I want to update anyway.  This new functionality has little use to me, but is still neat if you aren’t already using itunes to manage your podcast subscriptions. 

I have also been having an issue with wifi connecting to WPA protected APs, basically I would have to turn my wifi option on and then off and then back on again in order to get it to connect to any wireless.  Hopefully this new firmware will address that issue as well. 

UPDATE 11-24-08
   It turns out there is a way to download new episodes of your podcasts from the touch (using your existing subscriptions and not the built-in separate podcast client on the iphone/touch).  When you go into your podcasts and view the details of them, there is a new option as you scroll down to “Get more episodes”.  So even though itunes and the podcast client on the touch are two separate things, you can at least download new episodes of your current subscriptions.  I was confused since my subscriptions weren’t under the podcast menu button at the bottom.  You have to go into the podcasts you have synched on your iphone/touch as if you were going to listen to one, scroll down and there you will see how to download more content right from the touch.

Make your iTunes library portable

Now that I have an iPod Touch, I found that being limited to using iTunes on a single computer to sync and manage my library of music, podcasts and videos was a drag.  So I did some google searching and found that I could store my iTunes library on a portable hard drive and use iTunes on any computer (granted the iTunes version if the same).  I gave it a try, installed iTunes on two computers, made sure my portable hard drive was using the same drive letter on both computers and then began to setup my library.  As a result of all this work, I can now manage my library, sync my iPod and make changes anytime on either PC.  This works great and is very convenient for me.  Now I just need to get a dock for my desk and a few other accessories.  I didn’t find a need to post detailed instructions on my blog as there are many existing resources you can find with a simple google search on how to set this up.  Its very easy and works great, and I’d highly recommend it to anyone who wants to go mobile with iTunes.